Page 1 of 1

Prism API Download Issue

Posted: Wed Mar 22, 2017 3:29 pm
by FanOfHQ

I'm a fan of EveHQ and really like it. Thanks to all who contribute to it.

Prism started giving me a problem today. When I click the Download API Data button Some of the APIs in the chart are listed as "520" (in red text), instead of the typical date and time (in green text). I'm guessing the "520" is an error of some kind but I don't find any log about it. There's nothing in the EveHQ.log file that looks related to this.

The data related to the 520 entries seems to be unvailable. For example, one character has 520 under the Assets column, and Prism Assets now shows no assets for that character. Yesterday Prism API showed all the assets for that character across several locations.

What might be happening here and can I fix it?



Here's a screen snip of what's being shown:
Capture.PNG (7.38 KiB) Viewed 2685 times

Re: Prism API Download Issue

Posted: Wed Mar 22, 2017 4:54 pm
by FanOfHQ
Update: it's working again ...

I tried the Download API Data twice this morning, and restarted EveHQ in between, and waited until after the time listed on the chart (excluding the Assets API time) before the second attempt. I got the same 520 results on the second attempt as the first attempt.

But I just tried again, and no "520" results this time. So it's working now, as expected.

What does the "520" result mean? Is there something I can do to avoid it in the future?


Re: Prism API Download Issue

Posted: Wed Mar 22, 2017 5:00 pm
by Slivo
Hello there

I believe 520 are related to the CCP API not responding as expected, did you get those error during downtime ?

Re: Prism API Download Issue

Posted: Thu Mar 23, 2017 3:03 pm
by FanOfHQ
It was outside of downtime, but I see that it could have been an API issue. It's been fine since yesterday, so I'm good now.

Thanks again.