Prism Crashing since last update

Post Reply
Posts: 1
Joined: Mon Aug 07, 2017 2:07 am

Prism Crashing since last update

Post by sludgeface » Tue Aug 22, 2017 12:30 pm


As of the most recent version ( I can no longer view assets using the Asset Viewer in Prism. When I select a pilot or select all pilots, and then click refresh, the app seems to freeze and after a few moments, I am presented with this error:

*EveHQ Error Report*

EveHQ Version:
Date: 22/08/2017 08:30:04
Error: One or more errors occurred.
\\{panel:title=StackTrace|borderStyle=dashed|bordercolor=#ccc|titleBGColor=#eee|bgColor=#eee}*****START Aggregate Exception Details*****
Message: One or more errors occurred.
Source: mscorlib
StackTrace: at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
at EveHQ.Prism.Classes.Locations.GetStructureLocation(Int64 locationId) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Classes\Locations.vb:line 129
at EveHQ.Prism.Classes.Locations.GetLocationFromID(Int64 locationId) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Classes\Locations.vb:line 53
at EveHQ.Prism.Controls.PrismAssetsControl.PopulateAssetTree() in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Controls\PrismAssetsControl.vb:line 645
at EveHQ.Prism.Controls.PrismAssetsControl.PopulateAssets() in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Controls\PrismAssetsControl.vb:line 398
at EveHQ.Prism.Controls.PrismAssetsControl.RefreshAssets() in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Controls\PrismAssetsControl.vb:line 139
at EveHQ.Prism.Controls.PrismAssetsControl.btnRefreshAssets_Click(Object sender, EventArgs e) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.Prism\Controls\PrismAssetsControl.vb:line 130
at System.Windows.Forms.Control.OnClick(EventArgs e)
at DevComponents.DotNetBar.ButtonX.OnClick(EventArgs e)
at DevComponents.DotNetBar.ButtonX.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevComponents.DotNetBar.PopupItemControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
*****Inner Exceptions*****
*****START Exception Details*****
Message: Null object cannot be converted to a value type.
Source: mscorlib
StackTrace: at System.Convert.ChangeType(Object value, Type conversionType, IFormatProvider provider)
at Newtonsoft.Json.Linq.Extensions.Convert[T,U](T token)
at Newtonsoft.Json.Linq.Extensions.Value[T,U](IEnumerable`1 value)
at EveHQ.NewEveApi.StructureNameClient.GetStructureDataFromJson(String response, HttpStatusCode responseStatusCode, DateTimeOffset cacheTime) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.NewEveAPI\StructureNameClient.cs:line 79
at EveHQ.NewEveApi.StructureNameClient.ProcessServiceResponse(Task`1 webTask, String cacheKey, Int32 defaultCacheSeconds) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.NewEveAPI\StructureNameClient.cs:line 67
at EveHQ.NewEveApi.StructureNameClient.<>c__DisplayClass1_0.<GetStructureNameAsync>b__0(Task`1 webTask) in B:\Projects\GitHub\EveHQ-Team\EveHQ\EveHQ.NewEveAPI\StructureNameClient.cs:line 45
at System.Threading.Tasks.ContinuationResultTaskFromResultTask`2.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
*****END Exception Details*****
*****END Aggregate Exception Details*****

========== Plug-ins ==========

EveHQ.HQF.dll (
EveHQ.KillMailViewer.dll (
EveHQ.Prism.dll (
EveHQ.Void.dll (

========= System Info =========

Operating System: Microsoft Windows NT 6.2.9200.0
.Net Framework Version: 4.0.30319.42000
EveHQ Location: C:\Program Files (x86)\EveHQ
EveHQ Cache Locations: C:\Users\curti\AppData\Roaming\EveHQ

I have tried rolling back to the previous version of EveHQ and prism functions normally.

I have also tried a completely clean new install of EveHQ and the same issue occurs.

User avatar
Posts: 849
Joined: Tue Dec 30, 2014 12:51 am

Re: Prism Crashing since last update

Post by Slivo » Thu Aug 24, 2017 10:10 am

Hello sludgeface

Thanks for reporting this issue.
Did you follow the following steps when reinstalling EveHQ from fresh ? viewtopic.php?f=2&t=184
Would you provide our dev your API keys in case or data folder in case the issue isn't solved ?

I'm creating an issue for your problem so it can be processed. see

As I cannot reproduce it myself, is there some details that could help to understand what's going on ?

Posts: 11
Joined: Wed Jul 05, 2017 7:18 pm

Re: Prism Crashing since last update

Post by Eshva » Thu Aug 24, 2017 5:55 pm

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests